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Contacting us and getting help 
 
 

 
Please refer to our Latest News Page which you can access via the Help tab in 4Matrix (and at 
www.4matrix.com/news) for details of any urgent issues. 
 
Please do not telephone us for help with using 4Matrix on Exam Results Days. 
For any queries please check our extensive Knowledgebase or log a support ticket at 
www.help.4matrix.com. When creating a ticket, please describe the details, attach 
screenshot(s) of any error messages and your 4Matrix version number. To check which version 
of 4Matrix you are using, go to the Help tab and then About 4Matrix. 
 
We expect to be busy and will prioritise and respond to all live chats and tickets as quickly as 
possible. This guide is designed to be used alongside the Admin and KS4 Application Guides 
which give full details of how to use 4Matrix.  These can be accessed via the Help tab in 
4Matrix or via our website. 
 
On KS4 results days, our live chat and ticket support services will be available from: 

• 8am – 5pm Wednesday 14th August (GCE Results) 
• 8am – 5pm Thursday 15th August (GCE Results) 

 
Other than for the KS4 and KS5 results days we will be offering a reduced support service 
throughout the rest of the holiday period, details of which will be published on our news page.  
 

 
Preparation 
 

 
It is important that users familiarise themselves with the import process prior to results days. 
We will be unable to provide support for basic training on these days. 
 
If your school uses SIMS or Bromcom we recommend that you check that the Extract Tool is 
functioning correctly by carrying out a complete import of last year’s results data.  
For SIMS users, the extraction tool will only work if SIMS is hosted on site at the school. 
Hosted SIMS users should refer to www.4matrix.com/simsreports for more information. 
 
If you intend to import your results using a spreadsheet, we advise that you work through the 
import process and create a Map file ready to use on Results Day. You can also create a Map 
based on an existing series via Admin > Edit Subjects > File menu. 
 
Please check the subjects are linked to the correct QAN codes for each qualification as covered 
in Subject Mappings on Page 5. 
 
Students’ KS4 APS should be checked.  Please see our Pre Results Day Checklist for KS5 
available at:  www.4matrix.com/help/Pre_Results_Day_Checklist_2019_KS5.pdf 

 
We strongly recommend that schools launch 4Matrix on the Tuesday prior to results day to 
allow any pending updates to apply. If 4Matrix is not updating, please follow the process 
detailed in the Update Help guide to resolve the issue. 
 

 
Embargoing your exam results 
 
 
 
 
 
 
 
 

 
It is important to check the Visibility setting for all series that contain results. 
There are 3 default Access Levels in 4Matrix; Admin, SLT and Staff. Admin is the highest level, 
with access to the Admin tab and all data series. 
 
We recommend setting your series to Admin or SLT only on the Wednesday. Check prior to 
results day that your Head of Centre has granted early access to exam results. The visibility 
can then be switched to all staff on the Thursday after the candidates have received their 
results, in line with JCQ regulations. 
 

http://www.4matrix.com/news
https://help.4matrix.com/knowledgebase.php
https://help.4matrix.com/
http://www.4matrix.com/simsreports
http://www.4matrix.com/help/Pre_Results_Day_Checklist_2019_KS5.pdf
https://www.4matrix.com/help/update_help_new.pdf
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Embargoing your exam results 
Cont./ 

 
Series Visibility should ideally be set at the point of import but can be amended later by going 
to Admin > Edit Series, selecting the Visibility tab and highlighting the results series, setting the 
relevant Visibility option per user-group type using tick boxes.   
 
Choosing Admin will mean that only Admin users can see the series.  Choosing SLT will mean 
that Admin and SLT users can see the series, choosing Staff will grant all users access to the 
series.  
 
It is possible to set up additional custom Access Level groups in Admin > Manage Users. If you 
have done this make sure your groups have appropriate access by following the process above.  
 
If 4Matrix does not ask users to supply a username and password when launched, this 
indicates that 4Matrix is setup with Active Directory, please check with your IT Dept. which 
members of staff belong to each 4Matrix AD group – Admin, SLT and Staff (or others, if you 
have setup custom user-groups). 
 

 
Importing your exam results 
from SIMS/Bromcom 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
If you have been using 4Matrix to import tracking data, the most obvious difference on results 
day is that any exam results stored in the exams area will be picked up in the SIMS/Bromcom 
extract. If all results have been imported into the MIS, then there is no need to import a 
spreadsheet separately. 

 

To import your exam results from SIMS or Bromcom: 

Choose Admin > SIMS Extract or Admin > Bromcom Extract 

• Select Year 13 2018-2019 

• In Series, click [+] and select Actual 
Results or scroll down to the bottom, 
select Other and call the series 
‘Summer Results 2019’ or similar 

• Ensure that Visibility is set to Admin 
or SLT (or other appropriate groups) 
on restricted results days 

• In Step 2, choose Run 

• Choose a location to Save the extract 
to  

(e.g. My Documents\4Matrix Sims 
Extracts\)  

• Choose Run Extract 

 

See www.4matrix.com/videos for help with additional steps. 

 

 

http://www.4matrix.com/videos
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Importing your exam results 
from SIMS/Bromcom Cont./ 

 

 

Please consider the effective date of the extract. This should not be the current date, as the 
extract will only pick up students on roll, and leavers will not be included.  Choose an 
appropriate date – the date of the January census may be most suitable. 

Select the checkbox for Exam Results to be included in the 
extract. Please specify a date range using the Between 
option. For example, for the current Year 13 cohort the date 
range could be 01/01/2018 to 13/08/2019.  

The extract routine will import ALL exam results cached in by 
the student between the data range specified.  This will 
include any Key stage 4 results such as English and Math 
resits, and these cannot be imported into a Key Stage 5 
series in 4Matrix.  These columns will have to be removed by 
selecting the column, right mouse click under Remove 
choose Selected Column. 

Please note if any KS4 qualifications are imported these cannot be mapped into a Key Stage 5 
series in 4Matrix.  These columns can easily be removed by selecting the column, right mouse 
click under Remove choose Selected Column. 

The SIMS extract process will import the exam element title from Exams Organiser - this will 
not match existing subject titles in 4Matrix. Users will need to map to existing 4Matrix subjects, 
otherwise a new (duplicate) subject will be created and tools which compare subjects between 
series i.e. Series Comparison will not work as expected. Subjects can be merged later using 
Admin > Edit Subjects if this is ignored during the import. 

 
SIMS/Bromcom: 
Multiple Entries 
 
 

 
If the SIMS/Bromcom extract produces multiple results for the same subject, you will see a 
prompt asking you to select which grades to use. Please refer to this KB article for more 
information: https://help.4matrix.com/knowledgebase.php?article=210&suggest=1  

 
Importing your examination 
results from a spreadsheet 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Examination Results can be imported from a spreadsheet for users of any MIS. 
Create a Marksheet from the MIS containing pupil information columns (UPN, Forename, 
Surname, Gender) followed by subject results. Export the marksheet into Excel. 

Choose Admin > Spreadsheet > Pupils/Results:  

• Select Year 13 2018-2019  

• In Series, click [+] and select Actual 
Results or scroll down to the bottom, 
select Other and call the series 
‘Summer Results 2019’ or similar 

• Ensure that Visibility is set to Admin or 
SLT (or other appropriate groups) on 
restricted results days. 

• In Step 2, copy and paste in your 
results from your spreadsheet.   

You may also need to import pupil information, 
classes and other contextual data.  Please see 
the 4Matrix Guides for more information on 
this (via Help tab in 4Matrix). 

https://help.4matrix.com/knowledgebase.php?article=210&suggest=1
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Subject Mappings 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Schools are advised to ensure that their subjects are mapped to the correct awards using Edit 
Subjects. We will not be processing Missing Qualification requests on Results Days. 
 
You can produce a subject report for the active 
series containing each subject’s QAN, counting 
status and discount code using: Admin > Edit 
Subjects > File > Print Current Series Report. 
Schools are advised to check this against the 
relevant DfE documentation to ensure that 
each subject is being handled correctly. 
 
It is also possible to view a summary of subject 
information including QAN, counting status 
and discount code by using Help > Support 
Tools > See Inclusion 
Status.  This summary 
can be exported into 
Excel. 
 
The status of a subject 
(whether included or 
excluded in the 
performance measures) 
can be checked using the Mapped Qualification panel in the Edit Subjects tool but please do 
refer to the documentation mentioned above before making any changes. Note that you can 
search the qualification database in 4Matrix using QANs as the search term, i.e. 60001234 (do 
not include the / symbol). 
 
You can change the mapping of a subject in Admin > Edit Subjects by selecting it on the left and 
using the Change Map option. This will change the mapping for all series where the subject is 
used. You can move the grades from one subject to another for the active series only using the 
Move option. Please refer to the 4Matrix Admin Guide (available from the Help tab in 4Matrix) 
for more information.  
 

 
2019 Performance Measures 
 
 
 
 

 
At KS5, the headline measures include Average Points/Grade and Value-Added Progress Score. 
 
It is not possible to calculate KS5 Value Added in advance and schools are advised not to report 
the Value-Added scores shown in 4Matrix on results day. In 4Matrix we are using the most up-
to-date published coefficients, which are based on 2018 data.  We do not expect the 2019 data 
to be officially published (and validated) until March 2020, although the un-validated versions 
are expected in January 2020. As soon as this information is available to us, 4Matrix will be 
updated to use the new coefficients 
 
For Key Stage 5 Value Added, Key Stage 4 prior attainment data must be present in the 4Matrix 
Markbook (both ‘GCSE Only’ APS and ‘All’ APS) and details on how to import this can be found 
in the Pre Results Day Checklist for KS5 available at: 
www.4matrix.com/help/Pre_Results_Day_Checklist_2019_KS5.pdf 
It is not possible to check this data against DfE information until the September checking 
exercise opens. 
 

http://www.4matrix.com/help/Pre_Results_Day_Checklist_2019_KS5.pdf
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Checking your headline figures 
 
 
 
 
 
 
 
 
 
 
 
 
  

 
Do not report the information shown in 4Matrix without separately verifying it using other 
methods.  We will not accept any responsibility for the consequences of publishing incorrect 
information, however caused.  

• On the dashboard, check that the number of students in your cohort is correct. In 
Press Release check the number of students included in the scope for each 
performance measure-if numbers are not correct click on pupil breakdown to check 
the detail. 
 

• If you consider your AAB 2+ Facilitating figures to be incorrect check you are including 
the correct subjects by looking at Subjects Summary which tells you which subjects 
are facilitating or not. 
 

• If possible, compare the total number of entries against the figures in your MIS or 
spreadsheet, remembering that the number shown on the 4Matrix dashboard does 
not include discounted entries.  The total number of results contained in the series 
can be checked under Admin > Edit Series. 
 

• In Results Overview, check that all subjects are present.    
 

• In Subjects Summary, check the subject entries and APS against your last set of 
tracking data.  There will inevitably be some differences but a major change in either 
figure suggests a problem with results import.  
 

• In Value Added check that you have scores for subjects you expect to. 

 
Producing Reports 

 
You can produce reports from most tools in 4Matrix by going to File > Print.  
 

• The Press Release tool 
will report the main 
headline figures for your 
school. 

 

• Pupil Summary (under 
the Reports tab) can be 
used to produce 
certificates for pupils. 

 

• Full details of all reports 
can be found in the 
Application Guides  (via 
Help in 4Matrix). 
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We wish you all an enjoyable summer break and good luck! 

The 4Matrix Team 

 

 

 

 

 

 

 

 

 

 

 

 

   
Useful Links 

 

 
• 4Matrix News Page:  www.4matrix.com/news 

 
• PDF versions of the 4Matrix Application Guides www.4matrix.com/documentation 

 
• 4Matrix Help Desk/Support/Knowledgebase: www.help.4matrix.com 

 
• List of approved qualifications (KS5): https://www.gov.uk/government/publications/16-to-19-

qualifications-discount-codes-and-point-scores 
 

• 16 to 18 Accountability Measures: Technical Guide: 
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_d
ata/file/799994/16-18_Accountability_Measures_Technical_Guide.pdf 
 

• 16 to 18 Performance Tables – Discounting guidance for schools and colleges 2018:  
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_d
ata/file/762089/2018_16_to_18_Discounting_Guidance.pdf 
 

 

Join our Facebook group - It's a great place for school leaders and Data Managers to 
discuss secondary performance data, with over 500 members to date. We also talk about 

the latest 4Matrix developments, news, and share useful documents and resources. 

 

https://www.facebook.com/groups/4matrixdata/ 

http://www.4matrix.com/news
http://www.4matrix.com/documentation
http://www.help.4matrix.com/
https://www.gov.uk/government/publications/16-to-19-qualifications-discount-codes-and-point-scores
https://www.gov.uk/government/publications/16-to-19-qualifications-discount-codes-and-point-scores
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_data/file/799994/16-18_Accountability_Measures_Technical_Guide.pdf
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_data/file/799994/16-18_Accountability_Measures_Technical_Guide.pdf
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_data/file/762089/2018_16_to_18_Discounting_Guidance.pdf
https://assets.publishing.service.gov.uk/government/uploads/system/uploads/attachment_data/file/762089/2018_16_to_18_Discounting_Guidance.pdf

