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Contacting us and 
getting help 
 
 

 
Please refer to our Latest News Page which you can access via the Help tab in 4Matrix (and at 
www.4matrix.com/news) for details of any urgent issues. 
 
Please do not telephone us for help with using 4Matrix on Exam Results Days. 
For any queries please check our extensive Knowledgebase or log a support ticket at 
www.help.4matrix.com. When creating a ticket, please describe the details, attach screenshot(s) of 
any error messages and your 4Matrix version number. To check which version of 4Matrix you are 
using, go to the Help tab and then About 4Matrix. 
 
We expect to be busy and will prioritise and respond to all live chats and tickets as quickly as 
possible. This guide is designed to be used alongside the Admin and KS4 Application Guides which 
give full details of how to use 4Matrix.  These can be accessed via the Help tab in 4Matrix or via our 
website. 
 
On KS4 results days, our live chat and ticket support services will be available from: 

• 8am – 5pm Wednesday 21st August (GCSE Results) 

• 8am – 5pm Thursday 22nd August (GCSE Results) 

 

Other than for the KS4 and KS5 results days we will be offering a reduced support service throughout 
the rest of the holiday period, details of which will be published on our news page.  
 

 
Preparation 
 

 
It is important that users familiarise themselves with the import process prior to results days. We 
will be unable to provide support for basic training on these days. 
 
If your school uses SIMS or Bromcom we recommend that you check that the Extract Tool is 
functioning correctly by carrying out a complete import of last year’s results data.  
For SIMS users, the extraction tool will only work if SIMS is hosted on site at the school. Hosted 
SIMS users should refer to www.4matrix.com/simsreports for more information. 
 
If you intend to import your results using a spreadsheet we advise that you work through the import 
process and create a Map file ready to use on Results Day. You can also create a Map based on an 
existing series via Admin > Edit Subjects > File menu. 
 
Please check the subjects are linked to the correct QAN codes for each qualification as covered in 
Subject Mappings on Page 5. 
 
Students’ KS2 Fine Level should have been checked against the DfE checking data released during 
the June Checking Exercise.  Please see our checking exercise documentation for more information 
which is available from www.4matrix.com/news   
 
We strongly recommend that schools launch 4Matrix on the Tuesday prior to results day to allow 
any pending updates to apply. If 4Matrix is not updating, please follow the process detailed in the 
Update Help guide to resolve the issue. 
 

 
Embargoing your 
exam results 
 
 
 
 
 
 
 

 
It is important to check the Visibility setting for all series that contain results. 
There are 3 default Access Levels in 4Matrix; Admin, SLT and Staff. Admin is the highest level, with 
access to the Admin tab and all data series. 
 
We recommend setting your series to Admin or SLT only on the Wednesday. Check prior to results 
day that your Head of centre has granted early access to exam results. The visibility can then be 
switched to all staff on the Thursday after the candidates have received their results, in line with 
JCQ regulations. 
 

http://www.4matrix.com/news
https://help.4matrix.com/knowledgebase.php
https://help.4matrix.com/
http://www.4matrix.com/simsreports
http://www.4matrix.com/news
https://www.4matrix.com/help/update_help_new.pdf
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Embargoing your 
exam results Cont./ 

 
Series Visibility should ideally be set at the point of import but can be amended later by going to 
Admin > Edit Series, selecting the Visibility tab and highlighting the results series, setting the 
relevant Visibility option per user-group type using tick boxes.   
 
Choosing Admin will mean that only Admin users can see the series.  Choosing SLT will mean that 
Admin and SLT users can see the series, choosing Staff will grant all users access to the series.  
 
It is possible to set up additional custom Access Level groups in Admin > Manage Users. If you have 
done this make sure your groups have appropriate access by following the process above.  
 
If 4Matrix does not ask users to supply a username and password when launched, this indicates that 
4Matrix is setup with Active Directory, please check with your IT Dept. which members of staff 
belong to each 4Matrix AD group – Admin, SLT and Staff (or others, if you have setup custom user-
groups). 
 

 
Importing your exam 

results from 

SIMS/Bromcom 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If you have been using 4Matrix to import tracking data, the most obvious difference on results day is 

that any exam results stored in the exams area will be picked up in the SIMS/Bromcom extract. If all 

results have been imported into the MIS then there is no need to import a spreadsheet separately. 

To import your exam results from SIMS or Bromcom: 

Choose Admin > SIMS Extract or Admin > Bromcom Extract 

• Select Year 11 2018-2019 

• In Series, click [+] and select Actual Results or scroll 

down to the bottom, select Other and call the series 

‘Summer Results 2019’ or similar 

• Under Discounting make sure that for official 

reporting it is set to Use First Entry (All Subjects) 

• Ensure that Visibility is set to Admin or SLT (or other 

appropriate groups) on restricted results days 

• In Step 2, choose Run 

• Choose a location to Save the extract to  

(e.g. My Documents\4Matrix Sims Extracts\)  

• Choose Run Extract 

• See www.4matrix.com/videos for help with additional steps 

Please consider the effective date of the extract. This should not be the current date, as the extract 
will only pick up students on roll, and leavers will not be included.  Choose an appropriate date – the 
date of the January census may be most suitable. 

The SIMS extract process will import the exam element title from Exams Organiser - this will not 
match existing subject titles in 4Matrix. Users will need to map to existing 4Matrix subjects, 
otherwise a new (duplicate) subject will be created and tools which compare subjects between 
series i.e. Series Comparison will not work as expected. Subjects can be merged later using Admin > 
Edit Subjects if this is ignored during the import. 

Depending on setup, both the SIMS and Bromcom extracts may import duplicate columns for split-
level subjects i.e. Maths Foundation and Maths Higher. At the mapping stage, map each column to  

http://www.4matrix.com/videos
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Importing your exam 

results from 

SIMS/Bromcom Cont./ 

 

 

the same subject/QAN and complete the import. They can be left as split-level subjects or merged 
using Admin > Edit Subjects. 

 
SIMS/Bromcom: 
Multiple Entries 
 
 
 

 
If the SIMS or Bromcom extract produces multiple results for the same subject, or if you’re adding 

results to a series containing early entries, you will see a prompt asking you to select which grades to 

use. Please refer to this KB article for more information: 

https://help.4matrix.com/knowledgebase.php?article=210&suggest=1  

 
Importing your 
examination results 
from a spreadsheet 
 
 
 
 

 
Examination Results can be imported from a spreadsheet for users of any MIS. 
 
Create a Marksheet from the MIS containing pupil information columns (UPN, Forename, Surname, 

Gender) followed by subject results. Export the marksheet into Excel. 

Choose Admin > Spreadsheet > Pupils/Results:  

• Select Year 11 2018-2019  

• In Series, click [+] and select Actual Results or scroll 

down to the bottom, select Other and call the series 

‘Summer Results 2019’ or similar 

• Under Discounting make sure that for official 

reporting it is set to Use First Entry (All Subjects) 

• Ensure that Visibility is set to Admin or SLT (or other 

appropriate groups) on restricted results days. 

• In Step 2, copy and paste in your results from your 

spreadsheet.   

• You may also need to import pupil information, 

classes and other contextual data.  Please see the 

4Matrix Guides for more information on this (via Help in 4Matrix). 

 
Manually Adding or 
Adjusting Results 
 
 
 
 
 
 
 
 

 
During the import, results can be adjusted in Step 4: Validate Data, by either selecting a grade and 
changing it manually, or using the Find and Replace tool. If updating Science Trilogy grades, you 
must select the option to ‘Match Case’ and ‘Match Whole Cell’,  for example, when changing a 
grade 44 to 4-4. 
 
After the import, to manually add missing results, please use Admin > Edit Results.  If the subject is 
missing from Edit Results altogether you may need to use the Admin > Edit Subjects > Add Subject 
and then use the Edit Results > Show Subject option. Note that there is no “Save” button – all 
changes made in Edit Results take immediate effect. You can also create a spreadsheet with the 
missing results and import via Admin > Spreadsheet > Pupils/Results.  Instead of creating a new 
series at Step 1, select your existing result series and complete the import. 
 

 
 
 
 

 
 
 
 

https://help.4matrix.com/knowledgebase.php?article=210&suggest=1
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Notes on Pearson 
BTEC qualifications 
 

 
There are some qualifications that when taken do not count in performance tables but include the 
same content as a smaller qualification which does count in performance tables.  
 
It is our understanding that in this case, the awarding organisation will award the learner the larger 
qualification and the school will be credited with the smaller qualification which does count in 
performance measures. All qualifications that are affected by this are included in the BTECs tab in 
the approved list of qualifications (link below on page 7). 
 
Schools will need to check with Pearson which pupils will automatically receive a grade in smaller 
qualifications, and how the grade conversion will work (as the grade structure will be different 
between larger and smaller versions of the same qualification).  
 
This is not something that 4Matrix can account for automatically and schools will need to remain 
vigilant on exam results day and check that all grades are present.  Users should also check Grade 
Analysis to ensure that the correct grade is counting for pupils affected by this scenario. 
 

 
Subject Mappings 

 
Schools are advised to ensure that their subjects are mapped to the correct awards using Edit 
Subjects. We will not be processing Missing Qualification requests on Results Days. 
 
You can produce a subject report for the active series containing each subject’s QAN, counting status 
and discount code using: Admin > Edit Subjects > File > Export > Current Series Report. Schools are 
advised to check this against the relevant DfE documentation to ensure that each subject is being 
handled correctly. 
 
It is also possible to view a summary of subject information including QAN, counting status and 
discount code by using Help > Support Tools > See Inclusion Status.  This summary can be exported 
into Excel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The status of a subject (whether included or excluded in the performance measures) can be checked 
using the Mapped Qualification panel in the Edit Subjects tool but please do refer to the 
documentation mentioned above before making any changes.  
 
Note that you can search the qualification database in 4Matrix using QANs as the search term, i.e. 
60001234 (do not include the / symbol). 
 
You can change the mapping of a subject in Admin > Edit Subjects by selecting it on the left and 
using the Change Map option. This will change the mapping for all series where the subject is used. 
You can move the grades from one subject to another for the active series only using the Move 
option. Please refer to the 4Matrix Admin Guide (available from the Help tab in 4Matrix) for more 
information. 
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2019 Performance 
Measures 

 
At KS4, there are 4 headline measures that will be reported in England; Progress 8, Attainment 8, 
EBacc APS and English and Maths Threshold. 4Matrix will produce these headline figures and more.  
 
It is not possible to calculate KS4 Progress 8 in advance and schools are advised not to report the 
Progress 8 scores shown in 4Matrix on results day.  
 
In 4Matrix we are using the most up-to-date published coefficients, which are based on 2018 
validated data.  We do not expect the 2019 data to be officially published (and validated) until 
January 2020, although the un-validated versions are expected in September 2019. As soon as this 
information is available to us, 4Matrix will be updated to use the new coefficients. 4Matrix does not 
handle students identified as Progress 8 outliers.  We will be running Share and Compare again this 
year – see page 7. 
 
The Grade Analysis tool will highlight any discounted grades/subjects by showing them in blue. 
Discounted grades will not appear in the Progress 8 tool. 
 
It is important that schools have an accurate and complete set of key stage 2 data and we strongly 
recommend the June Checking Exercise guidance has been completed as described in Page 1 under 
Preparation. 
 

 
Early Entries & 
Pathway Discounting  
 

 
The key features of reporting Early Entries are as follows: Where a pupil has more than one 
qualification with the same discount code, and where both qualifications count towards this year’s 
performance tables, credit will be given to the first one that is taken.  This is also true for any re-sits.  
Entries are not discounted by previous entries which do not count towards performance tables. 
 
4Matrix supports KS4 Pathway Discounting which affects English, Mathematics and Science. The first 
qualification that a pupil takes determines the pathway that they are on. 
 
Pupils on multiple pathways will not have all their results included in school figures, even in cases 
where discount codes are unique. For example, a pupil that takes GCSE Physics first will be on the 
Single Sciences pathway and any subsequent entries in Combined Science Trilogy will not be 
included.  Pathway discounting will only take place if the correct dates are attached to each relevant 
Subject/grade. 
 
4Matrix does not account for AS-Level discounting in any subject, but the workaround for this is to 
set the AS-Level Result Date prior to the corresponding GCSE using Admin > Edit Results. 
 

 
Discounting subjects 
with the same 
discount code 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Subject grades which are imported into 4Matrix from SIMS will be ‘date stamped’ 
with the first date of Exam season in which the exam was taken. This will help 
4Matrix to determine the ‘first result’ for discounting and pathway purposes at 
key stage 4. 
 
Series imported from Bromcom or a spreadsheet will be date stamped with the 
date of import. Once you have imported your series into 4Matrix, you should 
check how your qualifications are being handled and their discount codes.  
Go to Help > Support Tools > See Inclusion Status. This will display a table of 
qualifications from the active series and their inclusion statuses across multiple 
performance measures. You can export this via the File menu. Make a note of any 
subjects that have the same Discount Code. 
 
Now open Admin > Edit Results. Choose the column for these subjects. Click on 
each grade in the column and check and amend the result date to when the 
qualification exam was taken. You can navigate using the arrows. You can also use 
the Set Date button in the top right of this tool to set the result date for an entire subject. 
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Discounting subjects 
with the same 
discount code Cont./ 
 

 
Check the handling of your grades using Grade Analysis as it will show any discounted grades in 
blue. You may need to cross-reference any anomalies with the result date stored in SIMS, Bromcom 
or elsewhere for clarification on which qualification was taken first and go back and make the 
necessary date changes in Admin > Edit Results in 4Matrix. 
 

 
Checking your 
headline figures 
 
 
 
  

 
Do not report the information shown in 4Matrix without separately verifying it using other methods.  
We will not accept any responsibility for the consequences of publishing incorrect information, 
however caused. 
 
The following checks may be useful. You may wish to check your data in other ways. 
 

• On the dashboard, check that the number of students in your cohort is correct. 
 

• If possible, compare the total number of entries against the figures in your MIS or 
spreadsheet, remembering that the number shown on the 4Matrix dashboard does not 
include discounted entries.  The total number of results contained in the series can be 
checked under Admin > Edit Series. 

 

• In Grade Analysis, check that all subjects are present. Check for any blue grades. This will 
mean that the grade is excluded for some reason, either due to discounting or because it 
does not count in performance measures.  

 

• In Subject Summary, check the subject entries and APS against your last set of tracking 
data. There will inevitably be some differences but a major change in either figure suggests 
a problem with results import. 

 

• You can manually check your English/Maths Threshold figures by comparing the results in 
4Matrix against raw results in your MIS or spreadsheet (including only Y11).  Apply filters to 
your raw results and compare these to the figures reported in 4Matrix. 

 

• In the EBacc Analysis tool, unexpectedly low numbers of entries and/or point scores in any 
of the pillars may indicate an issue with subject mapping (usually related to the Science or 
English pillars). 

 

• In the Progress 8 tool check for any of the following, which may in some cases indicate 
missing or incorrectly discounted grades: 

o Students with non-doubled English basket grade (purple colour) 
o Students with fewer than 10 entries overall 
o Students with less than 3 grades in each of the EBacc and Open baskets 

 

 
Producing Reports 

 
You can produce reports from most tools 

in 4Matrix by going to File > Print.  Full 

details of all reports can be found in the 

Application Guides. 

• The Press Release tool will report 

the main headline figures for 

your school. 

• Pupil Summary (under the 

Reports tab) can be used to 

produce certificates for pupils. 
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Share and Compare 

 
We will be running our Share and Compare exercise again for 2019 which will allow 4Matrix schools 
to share anonymised results data for analysis. Last year we were able to release our own indicative 
Attainment 8 estimates based on 574 participating schools, which were very close to the national 
Attainment 8 estimates from the DfE. 
 
For 2019, Share and Compare will be bigger and better than ever, as we plan to collect subject-level 
data and provide information on comparative subject differences alongside the main headline 
figures. 
 
More details regarding Share and Compare will be sent to schools in due course.  There is no need to 
prepare for this in advance and the uploading of data into the Share and Compare area will not be a 
time-consuming exercise. 
 

 
Useful Links 

 

 

• 4Matrix News Page: www.4matrix.com/news 
 

• PDF versions of the 4Matrix Application Guides: 

www.4matrix.com/documentation 
 

• 4Matrix Help Desk/Support/Knowledgebase: www.help.4matrix.com 
 

• List of approved qualifications (KS4): 

https://www.gov.uk/government/publications/key-stage-4-

qualifications-discount-codes-and-point-scores 
 

• List of approved EBacc qualifications: 

https://www.gov.uk/government/publications/english-baccalaureate-

ebacc/english-baccalaureate-ebacc 
 

• KS4 Accountability Guide: 

https://www.gov.uk/government/publications/progress-8-school-

performance-measure 

 

 

Join our Facebook group - It's a great place for school leaders and Data Managers to 

discuss secondary performance data, with over 500 members to date. We also talk about 

the latest 4Matrix developments, news, and share useful documents and resources. 

https://www.facebook.com/groups/4matrixdata/ 

We wish you all an enjoyable summer break and good luck! 

The 4Matrix Team 

http://www.4matrix.com/news
http://www.4matrix.com/documentation
https://help.4matrix.com/
https://www.gov.uk/government/publications/key-stage-4-qualifications-discount-codes-and-point-scores
https://www.gov.uk/government/publications/key-stage-4-qualifications-discount-codes-and-point-scores
https://www.gov.uk/government/publications/english-baccalaureate-ebacc/english-baccalaureate-ebacc
https://www.gov.uk/government/publications/english-baccalaureate-ebacc/english-baccalaureate-ebacc
https://www.gov.uk/government/publications/progress-8-school-performance-measure
https://www.gov.uk/government/publications/progress-8-school-performance-measure
https://www.facebook.com/groups/4matrixdata/

